Страница 1 из 11
Модератор форума: dotbot 
Сообщество uCoz » Архивариус » Корзина » Не отображаются картинки
Не отображаются картинки
stalker1313
Сообщений: 60
Репутация: 0
Уровень замечаний:

Сообщение # 1 | 16:50:49
В блоке случайные фото часто не отображаются картинки, если в информере использовать код $FULL_PHOTO_DIRECT_URL$ как это исправить?.
PS Если использовать код $PHOTO_DIRECT_URL$ то изображения на месте, но он не подходит так как картинки очень маленькие, а при увеличении размытые.
Selena
Сообщений: 15657
Репутация: 1099

Сообщение # 2 | 17:30:18
stalker1313, а если использовать $FULL_PHOTO_URL$?

Отправляя сообщение о помощи, приводите ссылку на свой сайт. Это не считается рекламой, зато снимает массу вопросов.
stalker1313
Сообщений: 60
Репутация: 0
Уровень замечаний:

Сообщение # 3 | 18:03:39
Selena, тоже не получается: или пустые рамки или только текст
Selena
Сообщений: 15657
Репутация: 1099

Сообщение # 4 | 18:14:43
stalker1313, на тестовом сайте информер с параметрами Фотоальбомы · Материалы · В случайном порядке · Материалы: 12 · Колонки: 2 и с кодом $FULL_PHOTO_URL$ всё отображает. При клике на фото открывается страница с полным фото.


Отправляя сообщение о помощи, приводите ссылку на свой сайт. Это не считается рекламой, зато снимает массу вопросов.
stalker1313
Сообщений: 60
Репутация: 0
Уровень замечаний:

Сообщение # 5 | 18:27:03
Selena, можно ли изменить ваш код чтобы картинка была на всю ширину блока?
Selena
Сообщений: 15657
Репутация: 1099

Сообщение # 6 | 19:35:24
stalker1313, размер данной картинки устанавливается в настройках. "Размеры фотографии, выводимой на отдельной странице".

Отправляя сообщение о помощи, приводите ссылку на свой сайт. Это не считается рекламой, зато снимает массу вопросов.
stalker1313
Сообщений: 60
Репутация: 0
Уровень замечаний:

Сообщение # 7 | 19:56:25
Selena, сделал информер на 300 материалов процентов 50 из них белые пятна, остальные нормально. Как такое может быть?
Сообщение отредактировал stalker1313 - Понедельник, 10 Ноя 2014, 20:12:39
Yuri_G
Модератор форума
Сообщений: 4184
Репутация: 896

Сообщение # 8 | 20:16:43
Цитата stalker1313 ()
сделал информер на 300 материалов процентов 20 из них белые пятна, остальные нормально. Как такое может быть?
$FULL_PHOTO_DIRECT_URL$ - если загруженное изображение меньше, чем заданы параметры фото в настройках модуля. В итоге вы и получите белые пятна. Единственным выходом будет использовать переменную - $PHOTO_DIRECT_URL$ для отображения миниатюры(качество будет не идеальное немного размытое) при нажатии на которую открывается оригинал - $FULL_PHOTO_DIRECT_URL$

Загружайте фото строго не меньше того размера который задали в настройках модуля, если вы до этого загружали фото разных размеров(меньше заданных параметров в настройках модуля) и вот решили создать информер в итоге и имеем последствия, все нужно продумывать заранее.

Помогу мягко перейти на SSL, отредактировать базы данных, пишите на - luk4196@ya.ru
stalker1313
Сообщений: 60
Репутация: 0
Уровень замечаний:

Сообщение # 9 | 20:21:59
Ucoz_fan, то есть перезалить придется, спасибо. А как правильно в информере прописать отображение определенных категорий. Допустим у меня id категорий - 1, 12, 32 и я хочу чтобы фотографии показывались только из этих трех категорий
Yuri_G
Модератор форума
Сообщений: 4184
Репутация: 896

Сообщение # 10 | 20:25:52
Цитата stalker1313 ()
А как правильно в информере прописать отображение определенных категорий.
Редактируем информер и прописываем айдишки категорий - http://i.imgur.com/0AtGpus.png

Помогу мягко перейти на SSL, отредактировать базы данных, пишите на - luk4196@ya.ru
stalker1313
Сообщений: 60
Репутация: 0
Уровень замечаний:

Сообщение # 11 | 20:37:53
Оказывается надо было информер по новой создать)
Сообщество uCoz » Архивариус » Корзина » Не отображаются картинки
Страница 1 из 11
Поиск: