Страница 1 из 11
Модератор форума: webanet 
Сообщество uCoz » Архивариус » Решённые вопросы » Проблемы с редактором материала (Портятся HTML-теги)
Проблемы с редактором материала
skiff3460
Сообщений: 4
Репутация: 0

Сообщение # 1 | 11:55:50
Здравствуйте!
Проблемы с редактором материала следующие, а точнее, область "Краткое описание" :
При добавлении текстового материала с тегами, написанными в программе FontPage или в блокноте SynWrite, далее сохранение материала и последующего обновления страницы, портятся теги, при том, что "тег-мусор" появляется в тексте статьи. Тоже самое происходит с областью "Полный текст материала".
Не понимаю в чем проблема. Пользуюсь Google Chrome
Прикрепления: 5824325.png(33Kb) · 5917261.png(40Kb) · 0945111.png(437Kb)

Если долго ковыряться...
То чего-нибудь наковыряется...
Сообщение отредактировал skiff3460 - Пятница, 29 Авг 2014, 11:57:06
Selena
Сообщений: 15657
Репутация: 1099

Сообщение # 2 | 15:24:39
skiff3460, судя по второму скриншоту символы тегов в буфере Винды воспринимаются как текст. Можно прогнать материал через Блокнот и только потом вставлять. Должно помочь.

Отправляя сообщение о помощи, приводите ссылку на свой сайт. Это не считается рекламой, зато снимает массу вопросов.
skiff3460
Сообщений: 4
Репутация: 0

Сообщение # 3 | 06:54:23
Цитата Selena ()
Можно прогнать материал через Блокнот и только потом вставлять. Должно помочь.

Selena, вы немного не поняли - второй скрин, это текст после обновления страницы редактора материала (кнопочка "обновить страницу" или когда снова перехожу к редактированию материала). Это сам модуль редактора портит теги, превращая их в текст.
Проверил в браузере OPERA 12.17 - такая же батва. Еще проверю на Windows 7.....может у меня ХР криво работает....

Если долго ковыряться...
То чего-нибудь наковыряется...
Сообщение отредактировал skiff3460 - Понедельник, 01 Сен 2014, 07:10:36
AndOrZYX
Сообщений: 50
Репутация: 11

Сообщение # 4 | 07:26:50
skiff3460, у вас </span> за </p> в первом параграфе.
А на втором скрине его нет, span не закрыт. Видимо, редактор его выкинул, не найдя логики в структуре.
Прикрепления: 3755423.png(22Kb)
Сообщение отредактировал AndOrZYX - Понедельник, 01 Сен 2014, 07:34:48
skiff3460
Сообщений: 4
Репутация: 0

Сообщение # 5 | 06:26:54
Цитата AndOrZYX ()
у вас </span> за </p> в первом параграфе. А на втором скрине его нет, span не закрыт.....
AndOrZYX, да, я нашел косяк с тегами - должно быть так:
Код
<p align="justify"><span style="font-size: 11pt" "font face=Verdana">
Краткое содержание статьи!
</span></p>
Но на этом проблема не решилась, все равно редактор портит теги.....ладно буду проверять на других компах, винде, сайт новый создать, посмотрю как там будет.......... вдруг у меня на рабочем сайте какие-либо ошибки висят и т.д.

Добавлено (02 Сен 2014, 06:26:54)
---------------------------------------------

Цитата skiff3460 ()
все равно редактор портит теги....

Всё, разобрался с этим тегом - вообще не правильно записывал.
ДОЛЖНО БЫТЬ ТАК
Код
<p>
   <span style="color: #000; font-size: 11pt; font face: Verdana">
     { Краткое содержание статьи }
   </span>
</p>

БОЛЬШЕ ВОПРОСОВ ПО ЭТОЙ ТЕМЕ НЕ ИМЕЮ!

Если долго ковыряться...
То чего-нибудь наковыряется...
Сообщество uCoz » Архивариус » Решённые вопросы » Проблемы с редактором материала (Портятся HTML-теги)
Страница 1 из 11
Поиск: